
<!DOCTYPE html>
<!--==================================================
==================START: HEADER====================-->
<html lang="en">
	<head>
		
		<!--
macro: mainmeta (MCD 201610140350)
current date: 20200331112906
template: 
currentrequest: /apps/pbcs.dll/article?avis=OK&date=20200330&category=NEWS&lopenr=200339992&Ref=AR
currentrequestunmodified: /news/20200330/wild-onions-and-eggs-instant-replay
@templatetype: /apps/pbcs.dll/article?avis=OK&date=20200330&category=NEWS&lopenr=200339992&Ref=AR
@pagetype: article
app version: 2.0.444
-->
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta property="og:site_name" content="The Daily Ardmoreite" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> 
<meta name="msvalidate.01" content="7E15F9269E2CE66F2A488ABB04B5015E" />

		<title> Wild Onions and Eggs (instant replay) - News - The Daily Ardmoreite - Ardmore, OK</title>
<!-- Meta Tags - Global Article6 guid: 2A8B75B6-8ABE-40D9-94DE-F5A42C7F7B80-->
<meta name="description" content="I wrote this article 3 years ago, but worth sharing again.&nbsp;Although I grew up in Ottawa County, I have spent the last almost 15 years working in Delaware County. The last couple of years I have spent a good deal of time around Jay. I have been fortunate to make many new friends from that area, a lot with Native American heritage. Most of my life has been prominent with friends and traditions from the Ottawa and Craig County areas. It has been interesting to me that only 50 miles away" />
<meta property="bt:pubDate" content="20200330T09:00:00Z">
<meta property="bt:modDate" content="20200330T09:59:00Z">
<meta property="bt:keywords" content="column,grand&20lake,grove&20ok,grove&20sun,ray">
<meta property="bt:author" content="Donnie Ray">
<meta name="twitter:title" content="Wild Onions and Eggs (instant replay)">
<meta name="twitter:description" content="I wrote this article 3 years ago, but worth sharing again.
&nbsp;
Although I grew up in Ottawa County, I have spent the last almost 15 years working in Delaware County. The last couple of years I have spent a good deal of time around Jay. I have been fortunate to make many new friends from that area, a lot with Native American heritage. Most of my life has been prominent with friends and traditions from the Ottawa and Craig County areas. It has been interesting to me that only 50 miles away">
<meta property="og:title" content="Wild Onions and Eggs (instant replay)"/>
<meta property="og:description" content="I wrote this article 3 years ago, but worth sharing again.
&nbsp;
Although I grew up in Ottawa County, I have spent the last almost 15 years working in" />
<meta name="author" content="Donnie Ray">
	<meta name="twitter:card" content="summary">
	<meta name="twitter:image" content="https://www.ardmoreite.com/storyimage/OK/20200330/NEWS/200339992/AR/0/AR-200339992.jpg&MaxW=1200&MaxH=630">
	<meta property="og:image" content="https://www.ardmoreite.com/storyimage/OK/20200330/NEWS/200339992/AR/0/AR-200339992.jpg">
	<meta property="og:image:width" content="189">
	<meta property="og:image:height" content="247">
	<meta property="vf:unique_id" content="siteOK-pub382-2A8B75B6-8ABE-40D9-94DE-F5A42C7F7B80">
	<link rel="canonical" href="https://www.ardmoreite.com/news/20200330/wild-onions-and-eggs-instant-replay"/>
<link rel="amphtml" href="https://www.ardmoreite.com/news/20200330/wild-onions-and-eggs-instant-replay?template=ampart">
<script type="application/ld+json">
  {
    "@context": "http://schema.org",
    "@type": "NewsArticle",
    "mainEntityOfPage": {
		"@type": "WebPage",
		"@id": "https://www.ardmoreite.com/news/20200330/wild-onions-and-eggs-instant-replay"
	},
    "headline": "Wild Onions and Eggs (instant replay)",
    "image": {
       "@type": "ImageObject",
       	"url":"https://www.ardmoreite.com/storyimage/OK/20200330/NEWS/200339992/AR/0/AR-200339992.jpg",
       	"height": 247,
       	"width": 189
    },
    "url": "https://www.ardmoreite.com/article/20200330/NEWS/200339992",
    "thumbnailUrl": "https://www.ardmoreite.com/apps/pbcsi.dll/bilde?Site=OK&Date=20200330&Category=NEWS&ArtNo=200339992&Ref=AR",
    "dateCreated": "20200330T15:00:00Z",
    "datePublished": "20200330T15:00:00Z",
    "dateModified": "20200330T15:59:00Z",
    "author": [{"@type":"Person","name":"Donnie Ray"}],
    "creator": "Donnie Ray",
    "publisher": {
       "@type": "Organization",
       "name": "The Daily Ardmoreite",
       "logo": {
         "@type": "ImageObject",
         "url": "https://www.ardmoreite.com/Global/images/head/nameplate/ok-ardmore_logo.png"
       }
    },
    "articleSection": "News",
    "keywords": ["Columns","OK_grandlakenews.com","Food","ATM Middle Age Middle Class","column","grand lake","grove ok","grove sun","ray"],
    "isAccessibleForFree": "False",
	"hasPart":
	{
		"@type": "WebPageElement",
		"isAccessibleForFree": "False",
		"cssSelector" : ".paywall-is-accessible-for-free"
	},
	"isPartOf": {
    "@type": ["CreativeWork", "Product"],
    "name" : "",
    "productID": "ardmoreite.com:standard"
	}
  }
</script>
<meta property="fb:app_id" content="143435942403889"/>
<meta name="twitter:site" content="@Ardmoreite">
<meta property="og:type" content="article"/>
<meta property="article:opinion" content="false"/>

		<script type="text/javascript">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</script>
				        <link rel="stylesheet" type="text/css" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700|Roboto+Condensed:400,400i,700,700i|Crimson+Text:400,400i,700,700i|Rubik:400,500,700,900" crossorigin="anonymous" />
        <link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" type="text/css" crossorigin="anonymous" />
        <link rel="stylesheet" href="//cdn.gatehousemedia.com/assets/css/2.0.444/default.min.css" type="text/css" crossorigin="anonymous" />
		<style type="text/css">
	.ad-970x250 {
		min-height: 250px !important;
	}
	@media only screen and (min-width: 768px) {
		#ad-base-leaderboard-hp{
			margin: 3.236em auto;
		}
	}
	@media only screen and (max-width: 767px) {
		#ad-base-leaderboard-hp{
			margin: 0 auto;
		}
	}
	/*legacy-header*/
	.legacy-header #baseLeaderboard {
		margin-top:25px;
	}
	#header-content div#slidingBillboard.ad.text-center {
		padding: 0;
		margin: 0;
	}
	#article > div > section.article-v2-left > div.ad-container { clear: both; }
	@media only screen and (max-width: 768px) {
		#buckets > div.article-extra > h4.chatter-title {
		    font-size: 2em;
		}
	}
	section.article-v2-right > div.article-body.p402_premium > div.vendor-logo.byline-item > img{
		max-width: 150px;
	}
	#apoc-breaking-wrapper{position: relative;z-index:100;}
	article.summary .inner .related li {max-height:fit-content!important;}
    /*==== ARTICLE ======*/
		/*==== for taboola ======*/
    	.article-newsletter-signup,#dialog-message{
	    	display: none !important;;
    	}
    	@media only screen and (min-width: 768px) {
			#interstitial{display:none;}
		}
		#header-main-center{
			display: none;
		}
    	/*story strip article ad*/
    	/* cssUpdates branch*/
    	div.gh-slider-storyStrip > div.adInject > div > iframe {
			max-height:90px;
		}
    	/* cssUpdates branch*/
    	.gh-slider-caption h3:not(.is-truncated):not([style="word-wrap: break-word;"]){
			-webkit-line-clamp: 4;
		    text-overflow: ellipsis;
    	}
    	.article-meta-day,a:visited  {
			font-family: "Roboto Condensed","Helvetica Neue","Helvetica","Roboto","Arial",sans-serif;
			font-size: 18.662px;
			font-weight: bold;
			color: #698096;
			display: block;
			font-kerning: normal;
			text-rendering: optimizeLegibility;
			margin-bottom: 10px;
			text-decoration: none;
		}
		#flipp-promo {
		    max-width: 300px;
		    margin: 0 auto;
		    max-height: 250px;
		 }
    	/* Viafoura email & password fields in registration/signup screens */
	 	.viafoura .vf-forgot-pw-link, .viafoura .vf-account-form {
	 		display: none;
	 	}
    	/*  TERMS OF SERVICE LINK - under viafoura comments submit button */
    	.vf-terms-of-service { margin-left: 12px;}
		/* TOUT MID ARTICLE PLAYER */
		.tout-mid-article { display:block; margin-right:2.35%; width:100%; }
	/* MOBILE article story stack */
    .gh-article-storyStack {
        background-color: #f3f3f3;
        display: inline-block;
        width: 100%;
        height: 150vw;
    }
    .gh-stacked {
        display: inline-block;
        padding: 2vw 2vw 4vw 2vw;
        margin: 0 0 3vw 0;
        height: 25vw;
        width: 100%;
    }
    .gh-stacked figure {
        width: 20vw;
        height: 20vw;
        display: inline-block;
        float: left;
        /* margin: 0 3vw 0 0; */
    }
    .gh-stacked h3 {
        width: calc(100% - 4.8em - 1.618em);
	    font-size: 1.25em;
	    line-height: 1.3em;
	    float: left;
	    display: inline;
    }
    .gh-article-storyStack .slick-slide .image{min-height:80px !important;}
    .gh-article-storyStack .slick-slide a{display:block;height:100%;width:100%;border-bottom: 1px solid #454545;margin-bottom:5px;}
</style>
		<style>
@media screen and (min-width: 768px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:lightskyblue;}
}
@media screen and (max-width: 767px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:#039be5;}
}
</style>
				<script type="text/javascript">
			window.supportsLocalStorage = false;
			try {
				window.supportsLocalStorage = !!window.localStorage
				    && typeof localStorage.getItem === 'function'
				    && typeof localStorage.setItem === 'function'
				    && typeof localStorage.removeItem === 'function';
			} catch(e) {
				console.error('localStorage error', e);
			}
			if(window.supportsLocalStorage === false) {
				console.warn('localStorage is not supported on this browser.');
			}
		</script>
		<script src="https://cdnjs.cloudflare.com/ajax/libs/jquery/2.1.4/jquery.min.js?20160411-3" crossorigin="anonymous"></script>
		<!-- Google Tag Manager -->
<script>
  //PAGE DATA
  __gh__coreData.pageData.type2 = "Article";
  __gh__coreData.pageData.error = __gh__coreData.pageData.type2 == "404" ? "404" : undefined;
  //USER
  __gh__coreData.user = {id:undefined,accessLevel:undefined};
  // Get clientside pieces from LocalStorage object
  if (window.supportsLocalStorage === true && typeof localStorage['_vxData'] != "undefined"){
    var _vxDataObj = JSON.parse(localStorage['_vxData']);
    __gh__coreData.user				= _vxDataObj;
  }
  //define main dataLayer for object for GTM
  window.dataLayer 	= window.dataLayer || [];
  dataLayer.push(__gh__coreData);
var __gh__gtm = {
	id:'GTM-WF5MZJ9'
};
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer',__gh__gtm.id);
</script>
<!-- End Google Tag Manager -->
		<script async='async' src='//cdn.adsafeprotected.com/iasPET.1.js'></script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/gannett-network/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
		<!--[if lte IE 9]>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js"></script>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv-printshiv.min.js"></script>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/respond.js/1.4.2/respond.min.js"></script>
		<![endif]-->
		<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "9289482" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=9289482&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

		
	</head>
<!--================================================
==================END: HEADER====================-->

	<body class="__PAGETYPE__">
		          
	<div id="fb-root"></div>
	
		<a href="#" id="backToTop"><i class="fa fa-chevron-up"></i></a>
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WF5MZJ9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

		<div id="wrapper-main">
				<script type="text/javascript">
  var TriggerPrompt = function(articleUrl, contentId) {
	if (!$(".p402_premium").length) {
		setTimeout(function(){ TriggerPrompt(articleUrl, contentId) }, 500);
		return;
	}
    var ARTICLE_URL = articleUrl ? articleUrl : window.location.href,
		CONTENT_ID 	= contentId ? contentId : 'everything',
		el 			= document.createElement('script'),
		url 		= '//survey.g.doubleclick.net/survey?site=_gxh7yhkux4nbuur7uj6d5mjamy' +
              '&url=' + encodeURIComponent(ARTICLE_URL) +
              (CONTENT_ID ? '&cid=' + encodeURIComponent(CONTENT_ID) : '') +
              '&random=' + (new Date).getTime() +
              '&after=1';
    el.setAttribute('src', url);
    var head = document.getElementsByTagName('head')[0] ||
        document.getElementsByTagName('body')[0];
    head.appendChild(el);
  };
  function pressplusAlternateAction() {
	__gh__webApp.paywall.showUserLoginForm();
  }
</script>

					<header id="header-main" class="header header-expanded no-gutter static clearfix">
			<div id="toprail">
	<div class="inner clearfix">
		<a id="button-nav-toggle"
			title="Navigation menu">
			<span class="hidden-sm hidden-xs">Sections</span>
			<i class="fa fa-fw fa-bars"></i>
		</a>
			<ul id="toprail-nav-left" class="list-inline"><li><a href="https://www.ardmoreite.com/news" target="_top">News</a></li><li><a href="https://www.ardmoreite.com/sports" target="_top">Sports</a></li><li><a href="https://www.ardmoreite.com/entertainment" target="_top">Entertainment</a></li><li><a href="https://www.ardmoreite.com/lifestyle" target="_top">Life</a></li><li><a href="https://www.ardmoreite.com/obituaries" target="_top">Obituaries</a></li><li><a href="http://ardmoredailyardmoreite.ok.newsmemory.com/" target="_top">E-Edition</a></li><li><a href="https://www.ardmoreite.com/section/cars" target="_top">Cars</a></li><li><a href="https://www.ardmoreite.com/jobs" target="_top">Jobs</a></li><li><a href="https://www.ardmoreite.com/homes" target="_top">Homes</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/OKArd" target="_blank">Classifieds</a></li></ul>
		<ul id="toprail-nav-right" class="list-inline">
				<li id="toprail-subscribe"><a href="https://www.ardmoreite.com/subscribenow?g2i_source=ardmoreite.com&g2i_medium=subscribe&g2i_campaign=topRail" target="_top" class="btn btn-sm btn-subscribe hidden-lg">Subscribe</a></li>
			<li id="toprail-search" class="hidden-sm hidden-xs">
											<div id="toprail-search-form">
								<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
									<script type="text/javascript">
	function searchArchive(archval){
		if(archval == 'archive'){
			document.location.href = 'http://nl.newsbank.com/nl-search/we/Archives?p_product=DAOB&p_theme=gatehouse&p_action=keyword';
		}else{
			return false;
		}
	}
</script>
<div class="input-group-btn">
	<button type="button" class="btn btn-default dropdown-toggle" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false"><span class="caret"></span></button>
	<ul class="dropdown-menu" id="searchparam_dd">
		<li data-type="site" class="selected">Site</li>
<li data-type="archive">Archive</li>
	</ul>
</div><!-- /btn-group -->
<script>
$(document).on('click', '#searchparam_dd li', function() {
	searchArchive($(this).data('type'));
});
</script>
									<input class="search-input" name="searchText" placeholder="Search this site" type="search">
									<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
								</form>
							</div>
							<i class="fa fa-fw fa-lg fa-search"></i>
			</li>
				<li id="toprail-login">
					<a class="hide" data-gh-paywall-event="login" href="/login">
						<i class="fa fa-user"></i>
						<span class="hidden-sm hidden-xs">Log in</span>
					</a>
				</li>
				<li id="toprail-weather" class="hidden-xs" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.ardmoreite.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#toprail-weather"></li>
		</ul>
	</div>
</div>
						<div id="header-main-nameplate">
				<div id="header-main-left">
					<div id="header-main-logo">
						<a href="https://www.ardmoreite.com">
							<img class="mainheadnameplate" src="https://www.ardmoreite.com/Global/images/head/nameplate/ok-ardmore_logo.png"  alt="The Daily Ardmoreite" />
						</a>
					</div>
				</div>
				<div id="header-main-center">
					<a href="https://www.ardmoreite.com/subscribenow?g2i_source=ardmoreite.com&g2i_medium=subscribe&g2i_campaign=header" target="_top" class="btn btn-subscribe">Subscribe Now</a>
				</div>
				<div id="header-main-right" class="hidden-xs">
					<div id="header-main-promo" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.ardmoreite.com/section/?template=ajaxPromoWiz7" data-gh-fetch-html-dom="#header-main-promo"></div>
				</div>
			</div>
		</header>


<!--==================================================
==========================START: CONTENT===========-->
			<div id="content" class="clearfix">
				

<div class="alert"></div>
<div id="apoc-breaking-wrapper" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.ardmoreite.com/section/breaking_ajax?template=breaking_ajax2" data-gh-fetch-html-dom="#apoc-breaking-wrapper"></div>
<div data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://cdn.gatehousemedia.com/gh-sites/global/breaking/breaking-special.html"></div>

				<div class="ad ad-billboard text-center" id='ad-base-leaderboard-article'>
	<div id="baseLeaderboard" data-size-mapping="baseLeaderBillboardArticle"></div>
	<div data-gh-object-loaded="false" 
		data-gh-object-offset="0" 
			data-gh-object='{"method":"__gh__webApp.utilities.adsRefresh.init","data":{"id":"baseLeaderboard-adRefresh","orgId":"baseLeaderboard","loadNow":"false","container":"ad-base-leaderboard-article"}}'
				class="ad-refresh" 
					data-gh-lazy-ad-bucket-targeting='{"ad-type":"standard","slot":"Base Leaderboard","sov":"base ROS","refresh":"true"}' 
						data-dimensions="[[970,90],[970,250],[728,90]]" 
							id="baseLeaderboard-adRefresh" 
							 data-size-mapping="baseLeaderBillboardArticle" 
								 data-gh-object-parent-height="true"></div>
</div>

				<div id="wrapper" class="clearfix">
					<div id="buckets">
	<article class="full article-v2 loading" data-updated="20200330095942">
	<div class="inner">
		<h1 class="headline">Wild Onions and Eggs (instant replay)</h1>
		<section class="article-v2-left">&nbsp;</section>
		<section class="article-v2-right">
			        <figure class="thumb">
            <img class="image" src="https://www.ardmoreite.com/storyimage/OK/20200330/NEWS/200339992/AR/0/AR-200339992.jpg&MaxH=200&MaxW=200" width="100%">
            <!--div class="image-caption">
                <div class="description"></div>
                <div class="credit"></div>
            </div-->
        </figure>
			<div class="article-body">
				<span class="byline-item">
					Donnie Ray
				</span>
				<div class="article-meta">
					<div class="inner">
						<div class="article-meta-main">
							<h3 class="article-meta-day">Monday</h3>
							<span class="article-meta-date">Mar&nbsp;30,&nbsp;2020&nbsp;at&nbsp;9:00&nbsp;AM</span>
							<span class="article-meta-updated">Mar&nbsp;30,&nbsp;2020&nbsp;at&nbsp;9:59&nbsp;AM</span>
						</div>
					</div>
				</div>
				<br><br>
				<div class="inner">
					<p class="article-summary"></p>
					<p><p>I wrote this article 3 years ago, but worth sharing again.</p>
<p>Although I grew up in Ottawa County, I have spent the last almost 15 years working in Delaware County. The last couple of years I have spent a good deal of time around Jay. I have been fortunate to make many new friends from that area, a lot with Native American heritage. Most of my life has been prominent with friends and traditions from the Ottawa and Craig County areas. It has been interesting to me that only 50 miles away from my home, that the culture in an area that close to me has traditions that are new to me. I always enjoy it when I am introduced to something new or different than what I am accustomed to. I have attended what they call Hog Fries and Gigging Tournaments. The people I have friended in that area have been more than happy to teach me some of their traditions and lifestyles different from mine. The art of gigging fish is a Cherokee tradition still practiced frequently in Delaware County. After dark, usually a two man team will take a flat bottomed boat and head up the clear creeks or rivers to gig fish using a long pole with a spearing apparatus on the end. Although I have been invited, I have never been gigging. But, I have attended the meal they prepare after bringing the fish in... The feast usually involves using a propane cooker filled with oil to cook fried onions, potatoes, hot links, fish, and fried biscuits.</p>
<p>Hog fries are another tradition to that area, which I have attended as well. Some of the finest eating I have ever participated in was at a hog fry. Recently at a hog fry I was quizzing the local cooks on their techniques of preparing their fine dining and was amazed at the simplicity to which they prepared things and yet, was producing such flavorful meals. But, I later learned that what made their fare so special was not the ingredients used but the know-how of the process of making things like, perfect fry bread, tender delicious fried hog meat, huckleberry bread, etc.</p>
<p>April is a great time in Delaware County, as it is the time of year that the annual gigging tournament is held at Lake Eucha, the perch fishing gets started, the wild mushrooms are ready for picking, as well as the wild onions, with the huckleberries coming on later in June and July. My only dislike of this area, this time of year is the emergence of the copperhead snakes coming out of hibernation. Oh yes, Delaware County produces lots of those as well! So if you&rsquo;re like me, I leave the harvesting to others and just purchase my huckleberries and wild onions. If you choose not to get out and pick any these delicious morsels, you CAN usually buy them from individuals who HAVE gotten out and picked, but they are not cheap. As with the wild mushrooms, huckleberries, or other wild growing fruit or vegetable it costs for seasonal delicacies, with the wild onions alone usually costing around $20 for a gallon bag. But it is a once a year tradition with a small timeline for harvesting, and well worth the cost if you have never tried them. A traditional Native American dish, wild onions and eggs, or as some call it Cherokee Eggs and Wild Onions are much sought after meal in the month of April in Delaware County and the most recognized way of enjoying these onions. I&rsquo;m sure there are other methods of preparing them, but in that part of the country, that would be the traditional way. The first time I was told we were having wild onions and eggs, I said, oh, for breakfast? Well, I quickly learned that they are served at dinner with fried potatoes, beans, etc.</p>
<p>Wild Onions and Eggs</p>
<p>Ingredients</p>
<p>1 cup or 2 Dozen Wild Onions</p>
<p>2 Tablespoons Water</p>
<p>6 Eggs</p>
<p>1-2 Tablespoons Bacon Grease or Butter for frying</p>
<p>Salt and Pepper to taste</p>
<p>Directions</p>
<p>1. Pick or buy young tender wild onions equal around 1 cup.</p>
<p>2. Coarsely chop the onions.</p>
<p>3. Place the onions and the water in a cast iron fryer. Cover and cook until they are limp.</p>
<p>4. Add butter or bacon grease.</p>
<p>5 Add eggs. Scramble and add salt and pepper to taste. Do not overcook.</p>
<p>Serve hot.</p></p>
				</div>
			</div>
		</section>
	</div>
</article>
</div>

				</div><!-- /wrapper -->
			</div><!-- /content -->

			<div id="push-main" class="clearfix"></div>
		</div><!-- /wrapper-main -->
<!--==================================================
====================END: CONTENT===================-->
				<footer id="footer-main" class="clearfix">
			<div class="inner container">
				<div id="footer-main-newsletter">
					<div id="footer-main-subscribe">
						<h2>Never miss a story</h2>
						<p>
							Choose the plan that's right for you.<br>
							Digital access or digital and print delivery.
						</p>
						<a href="https://www.ardmoreite.com/subscribenow?g2i_source=ardmoreite.com&g2i_medium=subscribe&g2i_campaign=footer" target="_top" class="btn btn-subscribe">Subscribe Now</a>
					</div>
								<h2>Sign up for daily e-mails</h2>
										<form id="sfNewsletterForm_footer" class="sfNewsletterForm form-inline">
			<input type="email" name="sfUserEmail" class="sfUserEmail" placeholder="Enter Email Address">
			<input type="hidden" name="sfSource" class="sfSource" value="footer">
			<input type="submit" name="sfSignup" class="sfSignup btn btn-newsletter" value="Sign Up Now">
			<div class="sfResults">
			</div>
		</form>
				</div>
				<div id="footer-main-info" data-gh-accordion-loaded="false" data-gh-accordion-panel-dom="#footer-main-info .footer-col ul" data-gh-accordion-toggle-dom="#footer-main-info &gt; .footer-col &gt; h4" data-gh-accordion-open-at="480">	<div class="footer-col"><h4>Site Services<i class="fa fa-angle-down"></i></h4><ul><li><a href="https://supportlocal.usatoday.com" target="_top">Support Local Businesses</a></li><li><a href="http://myprofile.ardmoreite.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=GTDT_TDA" target="_top">My Profile</a></li><li><a href="https://www.ardmoreite.com/contact" target="_top">Contact Us</a></li><li><a href="http://adportal.marketplaceadsonline.com/gatehouse-adportal/okard-classified/index.html" target="_blank">Place an Ad</a></li><li><a href="http://ardmoredailyardmoreite.ok.ussrv07v.newsmemory.com/index.php" target="_blank">E-Ardmoreite</a></li><li><a href="http://ardmoredailyardmoreiteprint.ok.newsmemory.com/code/en/gatehouse/subscription/step1" target="_blank">Manage Account</a></li><li><a href="http://nl.newsbank.com/nl-search/we/Archives?p_product=DAOB&amp;p_theme=gatehouse&amp;p_action=keyword" target="_blank">Archives</a></li><li><a href="http://ardmoreite.profootball.upickem.net/profootball/registration/login.asp" target="_blank">Pro Football Contest</a></li><li><a href="http://contests.ardmoreite.com/upickem/registration/login.asp?contestid=99796" target="_blank">College Football Contest</a></li><li><a href="http://contests.ardmoreite.com/upickem/registration/login.asp?contestid=144244" target="_blank">High School Football Contest</a></li><li><a href="http://mediakit.gatehousemedia.com/Ardmore_OK" target="_blank">Advertise With Us</a></li></ul></div><div class="footer-col"><h4>Market Place<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://www.marketplaceadsonline.com/marketplace/OKArd" target="_blank">Classifieds</a></li><li><a href="http://ardmoredailyardmoreite.ok.ussrv07v.newsmemory.com/marketplace.php" target="_blank">Today's Ads</a></li><li><a href="https://www.ardmoreite.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill </a></li></ul></div><div class="footer-col"><h4>Community Info<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://www.ardmorecity.org/" target="_blank">City of Ardmore</a></li><li><a href="http://www.ardmore.org/" target="_blank">Ardmore Chamber of Commerce</a></li><li><a href="http://www.ardmoreconventioncenter.com/index.php" target="_blank">Ardmore Convention Center</a></li><li><a href="http://visitors.ardmore.org/" target="_blank">Ardmore Tourism</a></li><li><a href="http://www.news-star.com" target="_blank">News-Star</a></li></ul></div><div class="footer-col"><h4>Site Links<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://ardmoreite.travidia.com/SS/Tiles.aspx" target="_blank">Special Sections</a></li><li><a href="http://files.gatehousemedia.com/upload/files/home/ghm_pubs/Ardmoreite_engagement_form-2015.pdf" target="_blank">Engagement Form</a></li><li><a href="http://files.gatehousemedia.com/upload/files/home/ghm_pubs/2011_NEW_wedding_form.pdf" target="_blank">Wedding Form</a></li><li><a href="http://files.gatehousemedia.com/upload/files/home/ghm_pubs/NEW_anniversary_announcement.pdf" target="_blank">Anniversary Form</a></li><li><a href="http://files.gatehousemedia.com/upload/files/home/ghm_pubs/birth.pdf" target="_blank">Birth Form</a></li></ul></div>
</div><!-- /footer-main-info -->
			</div><!-- /inner++++/apps/pbcs.dll/article?avis=OK&date=20200330&category=NEWS&lopenr=200339992&Ref=AR -->
			<div id="footer-main-copyright">
					<p id="footer-copyrightInfo">&copy; Gannett Co., Inc. 2020. All rights reserved.</p>
	<p>Original content available for non-commercial use under a Creative Commons license, except where noted.
	<br />The Daily Ardmoreite  ~ 117 W. Broadway, Ardmore, OK 73401<span class="gdpr hide"> ~ <a id="ot-sdk-btn" class="ot-sdk-show-settings" href="javascript:void(0);">Do Not Sell My Personal Information</a> ~ <a href="https://www.ardmoreite.com/section/cookie-policy" target="_blank">Cookie Policy</a></span><span class="gdpr-disabled hide"> ~ <a href="https://www.gannett.com/cookie-policy/" target="_blank">Do Not Sell My Personal Information</a></span> ~ <a href="http://www.gannett.com/privacy-statement/" target="_blank">Privacy Policy</a> ~ <a href="http://www.gannett.com/terms-of-use/" target="_blank">Terms Of Service</a> ~ <a href="https://www.gannett.com/ccpa/" target="_blank">Your California Privacy Rights / Privacy Policy</a></p>
	<p><a href="/ownership">Gannett | USA TODAY NETWORK</a></p>
			</div>
		</footer><!-- /footer -->
				<nav id="drawer" role="navigation">
			<a href="https://www.ardmoreite.com/subscribenow?g2i_source=ardmoreite.com&g2i_medium=subscribe&g2i_campaign=drawer" target="_top" class="btn btn-subscribe">Subscribe Now</a><hr>
			<div id="drawer-search" class="hidden-md hidden-lg">
				<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
					<div class="input-group-btn">
						<button type="button"
							class="btn btn-default dropdown-toggle"
							data-toggle="dropdown"
							aria-haspopup="true"
							aria-expanded="false">
							<span class="caret"></span>
						</button>
						<ul class="dropdown-menu" id="searchparam_dd">
							<li data-type="site" class="selected">Site</li>
							<li data-type="archive">Archive</li>
						</ul>
					</div>
					<input class="search-input" name="searchText" placeholder="Search Site" type="search">
					<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
				</form>
			</div>
			<hr class="hidden-md hidden-lg">
			<div class="inner">
				<div id="wrapper-drawer">
						<ul 
					 class="nav" 
					 data-gh-accordion-loaded="false" 
					 data-gh-accordion-panel-dom="#drawer-nav-sections .subnav" 
					 data-gh-accordion-toggle-dom="#drawer-nav-sections &gt; li &gt; a" 
					 id="drawer-nav-sections"
				   ><li><a href="https://www.ardmoreite.com" target="_top">Home</a></li><li><a href="https://www.ardmoreite.com/news"><span class="nav-category">News</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"453"><a href="https://www.ardmoreite.com/news/community" target="_top">Community</a></li><li id="navLink-TEST-"454"><a href="https://www.ardmoreite.com/news/court-news" target="_top">Court News</a></li><li id="navLink-TEST-"455"><a href="https://www.ardmoreite.com/news/education" target="_top">Education</a></li><li id="navLink-TEST-"456"><a href="https://www.ardmoreite.com/news/nation-world" target="_top">Nation & World</a></li><li id="navLink-TEST-"457"><a href="https://www.ardmoreite.com/news/police-fire" target="_top">Police & Fire</a></li><li id="navLink-TEST-"459"><a href="https://www.ardmoreite.com/news/state-news" target="_top">State News</a></li><li id="navLink-TEST-"458"><a href="https://www.ardmoreite.com/news/shareable" target="_top">Shareable</a></li></ul></li><li><a href="https://www.ardmoreite.com/sports"><span class="nav-category">Sports</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"462"><a href="https://www.ardmoreite.com/sports/high-school" target="_top">High School</a></li></ul></li><li><a href="https://www.ardmoreite.com/entertainment"><span class="nav-category">Entertainment</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"465"><a href="https://www.ardmoreite.com/entertainment/books" target="_top">Books</a></li><li id="navLink-TEST-"466"><a href="https://www.ardmoreite.com/entertainment/celebrity-news" target="_top">Celebrity News</a></li><li id="navLink-TEST-"467"><a href="https://www.ardmoreite.com/entertainment/movies" target="_top">Movies</a></li><li id="navLink-TEST-"468"><a href="https://www.ardmoreite.com/entertainment/music" target="_top">Music</a></li><li id="navLink-TEST-"38355"><a href="https://www.ardmoreite.com/calendar" target="_top">Calendar</a></li></ul></li><li><a href="https://www.ardmoreite.com/lifestyle"><span class="nav-category">Lifestyle</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"52172"><a href="http://www.timeandmoney.com" target="_top">Time and Money</a></li><li id="navLink-TEST-"472"><a href="https://www.ardmoreite.com/lifestyle/boomers" target="_top">Boomers</a></li><li id="navLink-TEST-"473"><a href="https://www.ardmoreite.com/lifestyle/faith" target="_top">Faith</a></li><li id="navLink-TEST-"474"><a href="https://www.ardmoreite.com/lifestyle/family" target="_top">Family</a></li><li id="navLink-TEST-"475"><a href="https://www.ardmoreite.com/lifestyle/food" target="_top">Food</a></li><li id="navLink-TEST-"476"><a href="https://www.ardmoreite.com/lifestyle/health" target="_top">Health</a></li><li id="navLink-TEST-"477"><a href="https://www.ardmoreite.com/lifestyle/home-garden" target="_top">Home & Garden</a></li><li id="navLink-TEST-"478"><a href="https://www.ardmoreite.com/lifestyle/pets" target="_top">Pets</a></li><li id="navLink-TEST-"479"><a href="https://www.ardmoreite.com/lifestyle/travel" target="_top">Travel</a></li></ul></li><li><a href="https://www.ardmoreite.com/opinion"><span class="nav-category">Opinion</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"482"><a href="https://www.ardmoreite.com/opinion/columns" target="_top">Columns</a></li><li id="navLink-TEST-"483"><a href="https://www.ardmoreite.com/opinion/editorials" target="_top">Editorials</a></li><li id="navLink-TEST-"484"><a href="https://www.ardmoreite.com/opinion/letters" target="_top">Letters</a></li></ul></li><li><a href="https://www.ardmoreite.com/business-news" target="_top">Business</a></li><li><a href="https://www.ardmoreite.com/obituaries" target="_top">Obituaries</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>More</header><li><a href="https://www.ardmoreite.com/photos" target="_top">Photos</a></li><li><a href="https://www.ardmoreite.com/videos" target="_top">Videos</a></li><li><a href="https://www.ardmoreite.com/calendar" target="_top">Calendar</a></li><li><a href="https://www.ardmoreite.com/severe-weather" target="_top">Severe Weather</a></li><li><a href="http://games.ardmoreite.com" target="_top">Games</a></li><li><a href="https://www.ardmoreite.com/contests" target="_top">Contests</a></li><li><a href="https://www.ardmoreite.com/ara" target="_top">Branded Content</a></li><li><a href="https://www.ardmoreite.com/submit" target="_top">Submit your news</a></li><li><a href="https://www.ardmoreite.com/section/promoted//?prx_adpz=2254" target="_top">From Our Advertisers</a></li><li><a href="https://www.ardmoreite.com/southern-kitchen" target="_top">Southern Kitchen</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Subscriber</header><li><a href="http://myprofile.ardmoreite.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=GTDT_TDA" target="_top">My Profile</a></li><li><a href="http://ardmoredailyardmoreite.ok.newsmemory.com/" target="_top">E-Edition</a></li><li><a href="https://www.ardmoreite.com/subscribenow" target="_top">Subscribe</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Market Place</header><li><a href="http://www.marketplaceadsonline.com/marketplace/OKArd" target="_blank">Classifieds</a></li><li><a href="http://findnsave.ardmoreite.com/" target="_top">Find-N-Save</a></li><li><a href="https://www.ardmoreite.com/section/cars" target="_top">Cars</a></li><li><a href="https://www.ardmoreite.com/jobs" target="_top">Jobs</a></li><li><a href="https://www.ardmoreite.com/homes" target="_top">Homes</a></li><li><a href="http://adportal.marketplaceadsonline.com/gatehouse-adportal/okard-classified/index.html" target="_blank">Place an Ad</a></li><li><a href="http://mediakit.gatehousemedia.com/Ardmore_OK" target="_blank">Advertise With Us</a></li><li><a href="https://www.ardmoreite.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill </a></li><li><a href="http://ardmoreite.thrivehive.com/" target="_blank">Digital Marketing Services</a></li></ul>
<footer id="footer-drawer">
	<hr>
	<ul class="drawer-nav-secondary nav">
		<li>
			<a href="mailto:yournews@ardmoreite.com">Feedback</a>
		</li>
		<li>
			<a href="/ownership">Ownership</a>
		</li>
		<li>
			<a href="https://www.gannett.com/terms-of-use/" target="_blank">Terms of Use</a>
		</li>
		<li>
			<a href="https://www.gannett.com/privacy-statement/" target="_blank">Privacy Policy</a>
		</li>
		<li>
			<a href="https://www.gannett.com/brands/" target="_blank">Gannett Publications</a>
		</li>
	</ul>
</footer>
				</div>
				<footer id="footer-drawer">
					<div id="drawer-weather" class="visible-xs-block text-center" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.ardmoreite.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#drawer-weather">
					</div>
					<ul class="social list-inline">
						<li>
							<a	href="http://www.facebook.com/pages/The-Ardmoreite/143707431292?ref=nf""
								target="_blank"
								title="The Daily Ardmoreite Facebook">
								<i class="fa fa-fw fa-facebook"></i>
							</a>
						</li>
						<li>
							<a	href="http://www.twitter.com/Ardmoreite""
								target="_blank"
								title="The Daily Ardmoreite Twitter">
								<i class="fa fa-fw fa-twitter"></i>
							</a>
						</li>
						<li>
							<a	href="/section/feed"
								target="_blank"
								title="The Daily Ardmoreite RSS Feed">
								<i class="fa fa-fw fa-rss"></i>
							</a>
						</li>
						<li>
							<a	href="https://www.ardmoreite.com/contact"
								title="Contact The Daily Ardmoreite">
								<i class="fa fa-fw fa-envelope"></i>
							</a>
						</li>
					</ul>
					<!-- <span id="drawer-copyrightInfo">&copy; 2015 __SITENAME__</span> -->
				</footer>
			</div><!-- /.inner -->
		</nav>
		<div id="drawer-fade-screen"></div>
		<div id="dialog-message" data-gh-object-loaded="false" data-gh-object='{"method":"__gh__webApp.messageCenter.load","data":{"storageKey":"messageCenter"}}' class="slideUp hide">
    <header>
        <h3 class="dialog-title">SUBSCRIBE TODAY</h3>
        <div class="dialog-controls">
            <i id="dialog-minimize" class="fa fa-fw fa-window-minimize"></i>
            <i id="dialog-close" class="fa fa-fw fa-lg fa-times"></i>
        </div>
    </header>
    <div class="inner">
        <div class="dialog-content">
           <p><span>Choose the plan that&rsquo;s right for you. Digital access or digital and print delivery.</span></p>
        </div>
	        <a href="http://ardmoreite.com/subscribenow" class="btn btn-highlight" data-gh-tracker-track-event-object='{"category":"message center pop up","action":"click-action","label":"http://www.ardmoreite.com/apps/pbcs.dll/article?avis=OK&date=20200330&category=NEWS&lopenr=200339992&Ref=AR"}'>
	            Learn More
	        </a>
    </div>
</div>

				<script type="text/javascript">
		__gh__coreData.pageData.pageType2 = "Article";
		</script>
		<script src="//cdn.gatehousemedia.com/gh-sites/global/ads/ads.js" crossorigin="anonymous"></script>
		<script src="//cdn.gatehousemedia.com/assets/2.0.444/app.min.js" crossorigin="anonymous"></script>
		<script>
window.googletag = window.googletag || {};
window.googletag.cmd = window.googletag.cmd || [];
</script>
<script>
  window.confiant = window.confiant || {};
  window.confiant.enable_integrations = ['gpt'];
  var pbjs = pbjs || {};
  pbjs.que = pbjs.que || [];
</script>
<script async="" src="https://confiant-integrations.global.ssl.fastly.net/JYokDAn2beiT-wdiDnha5IuKJm0/gpt_and_prebid/config.js"></script>
<script>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore( A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");</script>
<script async src="https://js-sec.indexww.com/ht/p/183763-221412910371223.js"></script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>
		<script>
		function __gh__init() {
		var delay = 100;
			var maxDelay = 45000;
			var __gh__asyncInit = setInterval(function() {
			    if (typeof $ !== 'undefined' && typeof __gh__webApp !== 'undefined') {
			    	try {
						__gh__webApp.init();
						__gh__webApp.articlePage.init();
					} catch (e) {
						console.error('webapp failed to initialize', e);
					}
			        clearInterval(__gh__asyncInit);
			    } else if (delay > maxDelay) {
			    	console.error('webapp init timed out');
			        clearInterval(__gh__asyncInit);
			    }
			    delay *= 2;
			}, delay);
		}
		</script>
		<script>__gh__init();</script>
			<script async src="//cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.5/js/bootstrap.min.js?201604-1" crossorigin="anonymous"></script>

		
<!--currenttimestamp: 2020-03-31&nbsp;11:29:06-->
	</body>
</html>
